Vector-Sort in C++ – Hacker Rank Solution


Problem

You are given N integers. Sort the N integers and print the sorted order.
Store the N integers in a vector. Vectors are sequence containers representing arrays that can change in size.

Declaration :

vector<int>v; (creates an empty vector of integers)

Size :

int size=v.size();

Pushing an integer into a vector :

v.push_back(x);(where x is an integer.The size increases by 1 after this.)

Popping the last element from the vector :

v.pop_back(); (After this the size decreases by 1)

Sorting a vector :

sort(v.begin(),v.end()); (Will sort all the elements in the vector)

Input Format :

The first line of the input contains N where N is the number of integers. The next line contains N integers.

Constraints :

  • 1 <= N <= 10^5
  • 1<= Vi <= 10^9, where Vi is the ith integer in the Vertex

Output Format :

Print the integers in the sorted order one by one in a single line followed by a space.

Sample Input :

5
1 6 10 8 4

Sample Output :

1 4 6 8 10


Vector-Sort in C++ – Hacker Rank Solution

Code:

#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;


int main() 
{
    /* Vector-Sort in C++ - Hacker Rank Solution Start */
    int n,i;
    cin >> n;
    vector<int> numbers(n, 0);
    for(i = 0; i < n; i++) 
    {
        cin >> numbers[i];
    }

    sort(numbers.begin(), numbers.end());

    for(i = 0; i < n; i++) 
    {
        cout << numbers[i] << " ";
    }
    /* Vector-Sort in C++ - Hacker Rank Solution End */
    return 0;
}

Disclaimer: The above Problem (Vector-Sort in C++ ) is generated by Hackerrank but the Solution is Provided by MultiplexCoder. This tutorial is only for Educational and Learning purposes.


 Tags:    hackerrank c++ solutions | Functions Discussions | C++ | HackerRank | student analysis C++ hackerrank solution | challenges C++ hackerrank solution | hackerrank C++ basic certification solutions | hackerrank-C++ certification solutions | basic data types hackerrank solution in c++ | variable sized arrays hackerrank solution in c++ | inherited code hackerrank solution in c++ | hackerrank c++ solutions github | hackerrank data structures solutions in c++ | hackerrank c++ class solution | pointer hackerrank solution in c++ | box it hackerrank solution in c++ | google | code | 2021 | amazon

Previous
Next Post »