Printing Tokens in C – Hacker Rank Solution


 

Problem

Given a sentence, S, print each word of the sentence in a new line.


Input Format

The first and only line contains a sentence, S.

Constraints

  • 1<=len(s)<=1000

Output Format

Print each word of the sentence in a new line.


Sample Input 0

This is C 

Sample Output 0

This
is
C

Explanation 0

In the given string, there are three words [“This”, “is”, “C”]. We have to print each of these words in a new line.

Sample Input 1

Learning C is fun

Sample Output 1

Learning
C
is
fun

Sample Input 2

How is that

Sample Output 2

How
is
that





Printing Tokens in C – Hacker Rank Solution

Code:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
    char *s;
    s = malloc(1024 * sizeof(char));
    scanf("%[^\n]", s);
    s = realloc(s, strlen(s) + 1);
    int len = strlen(s);
    for(int i = 0; i < len; i++) {
        if(s[i] == ' ') {
            printf("\n");
        }
        else {
            printf("%c", s[i]);
        }
    }
    free(s);
    return 0;
}

Disclaimer: The above Problem (Printing Tokens in C) is generated by Hackerrank but the Solution is Provided by MultiplexCoder. This tutorial is only for Educational and Learning purposes. Authority if any of the queries regarding this post or website fill the following contact form thank you.

Tags:

    hackerrank c solutions | Functions Discussions | C | HackerRank | student analysis C hackerrank solution | challenges C hackerrank solution | hackerrank C basic certification solutions | hackerrank-C certification solutions | basic data types hackerrank solution in c | variable sized arrays hackerrank solution in c | inherited code hackerrank solution in c | hackerrank c solutions github | hackerrank data structures solutions in c | hackerrank c class solution | pointer hackerrank solution in c | box it hackerrank solution in c

Previous
Next Post »