For Loop in C++ – Hacker Rank Solution

 

Objectives

A for loop is a programming language statement which allows code to be repeatedly executed.
The syntax for this isSyntax :

for ( <expression_1> ; <expression_2> ; <expression_3> )
    <statement>
  • expression_1 is used for intializing variables which are generally used for controlling terminating flag for the loop.
  • expression_2 is used to check for the terminating condition. If this evaluates to false, then the loop is terminated.
  • expression_3 is generally used to update the flags/variables.
  • A sample loop will be

Example :

for(int i = 0; i < 10; i++) {
    ...
}

Input Format

You will be given two positive integers, a and b (a<=b), separated by a newline.

Output Format

For each integer n, in the interval [a,b]:

  • If 1<=n<=9 then print the English representation of it in lowercase. That is “one” for 1, “two” for 2, and so on.
  • Else if n>9 and it is an even number, then print “even”.
  • Else if n>9 and it is an odd number, then print “odd”.

Sample Input

8
11

Sample Output

eight
nine
even
odd


For Loop in C++ – Hacker Rank Solution

Code:

#include <iostream>
#include <cstdio>
using namespace std;

int main() {
    // Complete the code.
    int a,b,i;
    char *str[] = {"one","two","three","four","five","six","seven","eight","nine","even","odd"};
    cin>>a;
    cin>>b;
    for(i=a;i<=b;i++)
    {
        if(i<=9)
        {
            cout<<str[i-1]<<"\n";
        }
        else
        {
            cout<<str[9+(i%2)]<<"\n";
        }
    }
    return 0;
}

Disclaimer: The above Problem (For Loop in C++) is generated by Hackerrank but the Solution is Provided by MultiplexCoder. This tutorial is only for Educational and Learning purposes. Authority if any of the queries regarding this post or website fill the following contact form thank you.
Previous
Next Post »